Blackboard Learn 9.1.13 System Requirements

Hardware Minimum Requirements

  • 1.5 GHz CPU or greater with minimum of 1GB RAM
  • Network adapter: LAN (Ethernet) or wireless (WiFi)
  • DSL or cable broadband Internet (Dial up is supported but not recommended)
  • 3G & 4G connections not recommended when taking tests
  • CD/DVD drive and speakers may be required; refer to course requirements

Operating Systems & Plugins

  • Windows XP, Vista, 7, 8
    • Windows XP 64-bit is not supported.
  • MAC OSX 10.6 or later
  • JAVA Runtime Environment 7 (Optional)
    • JRE is only required in order to use certain Blackboard features.
      • Learn collaboration tools virtual classroom and chat
      • Multiple-file uploads
      • Math equation editor
    • Sun JRE 7
    • JRE 6 may work for some, but not all Blackboard Learn features.
  • Adobe Flash Player 11
    • Flash Player is only required in order to view web-based media, such as YouTube videos.

Additional detail about these requirements, including download links for the Sun JRE and Adobe Flash Player is available at Blackboard's Student Help Website

Web Browsers

Blackboard Learn support four primary web browsers:

  • Internet Explorer (Versions 9 and 10)
  • Safari (Versions 5 and 6)
  • Firefox (Current release)
  • Chrome (Current release)

Additional detail about these supported web browsers, including download links is available at Blackboard's Student Help Website

Mobile Devices

  • Mobile browsers, such as the Safari browser for iPad, are not officially compatible with Blackboard.
  • A Blackboard Mobile Learn application is available for purchase as a companion tool to the Blackboard Learn course environment.
  • The app is only designed for viewing course content and performing light communications tasks.
  • Not all Blackboard course content will be compatible with the Blackboard Mobile Learn app.
  • Participation in Blackboard courses requires access to a fully supported laptop or desktop computer.

Technologies not supported:

The following technologies are not supported in SP 11:

  • Internet Explorer 6, 7
  • Firefox 1.x, 2.0, 3.0, 3.5, and 3.6
  • Safari 2.0, 3.x and any version on Windows
  • Windows XP 64-bit
  • Mac OSX 10.3, 10.4, 10.5
  • Java 5, although it may continue to work